Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google      Sign In   
  • Create Account

Photo

Technical Frustrations and How You Fixed Them

troubleshooting twitch

  • Please log in to reply
4 replies to this topic

#1 Celemourn

Celemourn

    Newbie


  • 8 posts

Posted 15 March 2014 - 10:58 PM

This thread is intended to offer a place for those of us who stream to share solutions that we've come up with to particularly vexing technical problems that we occasionally run into while streaming.  Hopefully the shared knowledge will help others spend more time streaming and less time messing with software.  Adding my entry below.


  • 0

#2 Celemourn

Celemourn

    Newbie


  • 8 posts

Posted 15 March 2014 - 11:07 PM

Problem:  The audio and video on my stream began getting out of sync.

 

Software: OBS 64bit and OBS 32bit

 

Symptoms:  Audio would be out of sync with the video, anywhere from 175ms behind, to well over 6 seconds behind.  The desktop audio and microphone audio are always in sync, regardless of the microphone source used, so it's the overall audio sync that was having issues.  When the problem first manifested, it could be solved by simply stopping and restarting the stream.  This worked for a few days.  After that, the audio was almost permanently out of sync, consistently at 800ms behind, and adjustments to the Global Time Offset setting in OBS's Advanced settings window were needed to correct it.  Finally, the amount of offset began to grow and stopped being consistent.

 

Solution:  The solution appears to be to increase the scene buffering time to a quantity greater than the delay you're experiencing. This has gotten things back in sync for me, and removes the need to use the Global Audio Time Offset.

 

Non-solutions: Adjustments to bitrate, audio quality, checking of the 'Force desktop audio to use video timestamps as a base for audio time' and 'Use Mic QPC timestamps' checkboxes in the advanced settings did not resolve the issue.  Kicking the computer also did not resolve the issue, and resulted in a stubbed toe.


  • 0

#3 RomanticsWes

RomanticsWes

    Advanced Member


  • 1,026 posts
  • LocationTexas

Posted 17 March 2014 - 12:10 PM

This is why I still don't use OBS. It has numerous technical issues with sound especially for me when using my external mixer and everything. Xsplit's sound codecs are garbage too but at least they work for me 100% of the time.


  • 0

#4 MrLuchador

MrLuchador

    Advanced Member


  • 126 posts

Posted 17 March 2014 - 01:59 PM

Can't say I've had much issues with OBS, but then I have nothing else to compare it to. 


  • 0
PSN: MrLuchador
Steam: MrLuchador
Twitch: www.twitch.tv/Mrluchador
XBL: LuckyMrLuchador

#5 Nahku

Nahku

    Advanced Member


  • 303 posts
  • LocationGA, USA

Posted 22 March 2014 - 01:42 PM

I had the desync issue as well a while back.  Completely reinstalling OBS, and cleaning out reg entries, fixed it for me (but I lost all my scenes).  I couldn't get it accurate enough playing with buffer/delay.  Haven't had any other issues with OBS really, and the price is perfect for me. ;)


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users